CentOS 7 - checking for libzip... configure: error: system libzip must be upgraded to version = 0.11


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

CentOS 7 - checking for libzip... configure: error: system libzip must be upgraded to version = 0.11

Ошибка при выполнении: ./configure --prefix=.... ..... .....

checking for libzip... configure: error: system libzip must be upgraded to version >= 0.11


Решение - это обрать вручную более новую версию libzip:

# rpm -e --nodeps libzip-devel  libzip
# cd /tmp/ 
# wget https://nih.at/libzip/libzip-1.2.0.tar.gz
# tar -zxvf libzip-1.2.0.tar.gz
# cd libzip-1.2.0
# ./configure
# make && make install


Обязательно обновить либы после этого:

# echo '/usr/local/lib64
/usr/local/lib
/usr/lib
/usr/lib64'>>/etc/ld.so.conf
# ldconfig -v
Индекс цитирования