Wordpress: Warning: Cannot modify header information - headers already sent by


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

Доступная цена


Ошибка "Warning: Cannot modify header information - headers already sent by" указывает на то, что в конфигурационным файле указаны какие-то символы не принадлежавшие скрипту, вирусы, пробелы, не законченный код, к примеру

wp-config.php:1 -- там часто перед < ? php стоят какие-то символы "п»ї< ? php", достаточно их убрать.


Если символы не видны, то необходимо сохранить файл в кодировке UTF-8 без BOM

  • Скачиваете Notepad2: http://www.flos-freeware.ch/notepad2.html
  • Открываете файл.
  • Выбираете File - Encoding - UTF-8 (а не UTF-8 with signature!!!) и нажимаете Save.
  • Загрузите обратно файл на сервер
Индекс цитирования