VestaCP - Ubuntu 18.04 - при установке ошибка The following signatures couldn't be verified because the public key is not available


Материал из Wiki - Iphoster - the best ever hosting and support. 2005 - 2020

Перейти к: навигация, поиск

Доступная цена

VestaCP - Ubuntu 18.04 - при установке ошибка The following signatures couldn't be verified because the public key is not available

Если при установке панели VestaCP на Ubuntu 18.04 возникает ошибка

E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:5 http://apt.vestacp.com/bionic bionic InRelease [2,187 B]
Err:5 http://apt.vestacp.com/bionic bionic InRelease
 The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 42C5B2130A1F7714
Get:6 http://nginx.org/packages/mainline/ubuntu bionic InRelease [2,862 B]
Err:6 http://nginx.org/packages/mainline/ubuntu bionic InRelease
 The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ABF5BD827BD9BF62
Reading package lists... Done
W: GPG error: http://apt.vestacp.com/bionic bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 42C5B2130A1F7714
E: The repository 'http://apt.vestacp.com/bionic bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://nginx.org/packages/mainline/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ABF5BD827BD9BF62
E: The repository 'http://nginx.org/packages/mainline/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree

то нужно установить пакеты gnupg, gnupg2 на Ubuntu 18.04 и перезапустить установку панели VestaCP с ключем --force:

# apt-get install gnupg gnupg2 -y
# bash vst-install.sh --force
Индекс цитирования