Ubuntu 18.04 - ошибка E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

Ubuntu 18.04 - ошибка E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation

Ошибка вида:

# sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com --recv 9DA31620334BD75D9DCB49F368818C72E52529D4
E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation

Решение - это доустановить пакет gnupg2:

# apt-get install gnupg2


Проверяем:

~# sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com --recv 9DA31620334BD75D9DCB49F368818C72E52529D4
Executing: /tmp/apt-key-gpghome.9zSruIM4RA/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com --recv 
9DA31620334BD75D9DCB49F368818C72E52529D4
gpg: key 68818C72E52529D4: public key "MongoDB 4.0 Release Signing Key <packaging@mongodb.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1
Индекс цитирования