PHP - Ubuntu 16.04 - configure: error: Cannot find OpenSSL's libraries


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

PHP - Ubuntu 16.04 - configure: error: Cannot find OpenSSL's libraries

При подготовке к сборке php 5.3.x - вылезла ошибка:

checking which regex library to use... php
checking whether to enable LIBXML support... yes
checking libxml2 install dir... /usr
checking for xml2-config path... /usr/bin/xml2-config
checking whether libxml build works... yes
checking for OpenSSL support... yes
checking for Kerberos support... yes
checking for krb5-config... no
checking for DSA_get_default_method in -lssl... no
checking for X509_free in -lcrypto... yes
checking for pkg-config... no
configure: error: Cannot find OpenSSL's libraries


Решение - доустановить 2 пакета:

# apt-get install libssl-dev pkg-config

Проверено на

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:        16.04
Codename:       xenial
Индекс цитирования