PHP - Ubuntu - ext-dom - the requested PHP extension dom is missing from your system


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

PHP - Ubuntu - ext-dom - the requested PHP extension dom is missing from your system

После выполнения:

# composer install

получаем серию ошибок: requires ext-dom * -> the requested PHP extension dom is missing from your system. :

  Problem 1
   - Installation request for dompdf/dompdf v0.8.3 -> satisfiable by dompdf/dompdf[v0.8.3].
   - dompdf/dompdf v0.8.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
 Problem 2
   - Installation request for phar-io/manifest 1.0.3 -> satisfiable by phar-io/manifest[1.0.3].
   - phar-io/manifest 1.0.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
 Problem 3
   - Installation request for phpunit/php-code-coverage 6.1.4 -> satisfiable by phpunit/php-code-coverage[6.1.4].
   - phpunit/php-code-coverage 6.1.4 requires ext-dom * -> the requested PHP extension dom is missing from your system.
 Problem 4
   - Installation request for phpunit/phpunit 7.5.16 -> satisfiable by phpunit/phpunit[7.5.16].
   - phpunit/phpunit 7.5.16 requires ext-dom * -> the requested PHP extension dom is missing from your system.
 Problem 5
   - Installation request for theseer/tokenizer 1.1.3 -> satisfiable by theseer/tokenizer[1.1.3].
   - theseer/tokenizer 1.1.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
 Problem 6
   - dompdf/dompdf v0.8.3 requires ext-dom * -> the requested PHP extension dom is missing from your system.
   - laravel/cashier v7.2.2 requires dompdf/dompdf ^0.8.0 -> satisfiable by dompdf/dompdf[v0.8.3].
   - Installation request for laravel/cashier v7.2.2 -> satisfiable by laravel/cashier[v7.2.2].


Решение - доустановить модуль для PHP php-xml:

# apt install php-xml
# systemctl restart apache2
Индекс цитирования