OpenCart - модуль UniShop - uni settings.php was encoded by the ionCube Encoder for PHP 5.4 and cannot run under PHP 7.1 or later

Материал из Wiki - Iphoster - the best ever hosting and support. 2005 - 2021
Перейти к:навигация, поиск

OpenCart - модуль UniShop - uni settings.php was encoded by the ionCube Encoder for PHP 5.4 and cannot run under PHP 7.1 or later

Ошибка после переноса сайта на наш хостинг:

 PHP Fatal error:  The file /home/user1/public_html/admin/controller/extension/module/uni_settings.php was encoded by the ionCube Encoder for PHP 5.4 and cannot run under PHP 7.1 or later.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

Отказался работать модуль шаблонов OpenCart --> Дополнения --> Модули --> UniShop - Настройки шаблона v2.4.3.0:

500 ошибка


На хостинге стоял PHP 7.4.x, поэтому пришлось переключить версию PHP на 5.6.x:
https://wiki.iphoster.net/wiki/Как_изменить_версию_PHP_в_панели_Cpanel

Индекс цитирования