ISPManager - upgrade php 5.3 to 5.5 via remi repo


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

Самые выгодные сервера‎


ISPManager - upgrade php 5.3 to 5.5 via remi repo

tested on CentOS 6 - 64bit


# yum remove php-*
# vi /etc/yum.repos.d/remi.repo
[remi-php55]
enabled=1


Если не подлючен remi - подключаем через :

# rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
# yum install fontconfig libtidy freetype libXpm libxslt 
# yum install libc-client libtiff t1lib recode pspell aspell libtool-ltdl
# yum install --disablerepo=* --enablerepo=remi --enablerepo=remi-php55 php php-bcmath php-cli php-common php-gd php-imap php-mbstring php-mcrypt php-mysql php-pdo php-soap php-tidy php-xml php-xmlrpc php-pecl-apc phpMyAdmin roundcubemail php-opcache php-xdebug
# /etc/init.d/mysqld restart
# /usr/local/ispmgr/sbin/pkgctl cache
# /usr/local/ispmgr/sbin/pkgctl activate myadmin
# /usr/local/ispmgr/sbin/pkgctl activate webmail
# /etc/init.d/httpd restart


# php -v
PHP 5.5.31 (cli) (built: Jan  6 2016 13:27:11)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
   with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
   with Xdebug v2.3.3, Copyright (c) 2002-2015, by Derick Rethans


Если стала вылазить ошибка:

Thu Apr  7 06:49:11 2016 (913): Fatal Error Unable to allocate shared memory segment of 134217728 bytes: mmap: Cannot allocate memory (12)

то можно убрать opcache:

 # yum remove php-opcache


Также при ошибках об зависимостях смотрите тут:



Remi Repo link:

Индекс цитирования