ISPManager - install php 5.2.17 - old version


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

Самые выгодные сервера‎


Установка php 5.2.17 для ISPmanager (Centos 6 - 64bit)

atomic убрал php 5.2.17 для centos 6, поэтому берем тут

http://yum.mchost.ru/pub/php52/centos/6/x86_64/RPMS/
или
http://yum1.corp.eurobyte.ru/eurobyte-php52/centos/6/x86_64/RPMS/


Подготовка:

# yum remove php-*
# cd /root/ && mkdir new_php && cd new_php
# wget -r http://yum.mchost.ru/pub/php52/centos/6/x86_64/RPMS/
# mv yum.mchost.ru/pub/php52/centos/6/x86_64/RPMS/* ./
# yum install t1lib.x86_64 libevent.x86_64 freetype.x86_64 libjpeg libpng.x86_64 libXpm.x86_64 libtool-ltdl.x86_64 
libc-client.x86_64 freetds.x86_64 libxslt.x86_64 libtidy

Install php 5.2.17:

# rpm -Uhv php-5.2.17-r4686.mchost.x86_64.rpm php-cli-5.2.17-r4686.mchost.x86_64.rpm 
php-common-5.2.17-r4686.mchost.x86_64.rpm php-mcrypt-5.2.17-r4686.mchost.x86_64.rpm 
php-mbstring-5.2.17-r4686.mchost.x86_64.rpm php-gd-5.2.17-r4686.mchost.x86_64.rpm 
php-pdo-5.2.17-r4686.mchost.x86_64.rpm php-imap-5.2.17-r4686.mchost.x86_64.rpm 
php-mssql-5.2.17-r4686.mchost.x86_64.rpm php-mysql-5.2.17-r4686.mchost.x86_64.rpm 
php-soap-5.2.17-r4686.mchost.x86_64.rpm php-tidy-5.2.17-r4686.mchost.x86_64.rpm php-xml-5.2.17-r4686.mchost.x86_64.rpm
Preparing... ########################################### [100%] 
WARNING : These php-* RPM are not official Fedora/Redhat build and overrides the official ones. Don't file bugs on Fedora Project nor Redhat.
Use dedicated forums http://forums.famillecollet.com/
1:php-common ########################################### [ 8%] 2:php-pdo ########################################### [ 15%] 3:php-cli ########################################### [ 23%] 4:php ########################################### [ 31%] 5:php-mssql ########################################### [ 38%] 6:php-mysql ########################################### [ 46%] 7:php-mcrypt ########################################### [ 54%] 8:php-mbstring ########################################### [ 62%] 9:php-gd ########################################### [ 69%] 10:php-imap ########################################### [ 77%] 11:php-soap ########################################### [ 85%] 12:php-tidy ########################################### [ 92%] 13:php-xml ########################################### [100%]

and last step:

# rpm -Uhv php-ioncube-4.6.1-r5406.mchost.x86_64.rpm php-zend-3.3.9-r4687.mchost.x86_64.rpm

Включаем ioncube:

# vi /etc/php.d/ioncube.ini
# /etc/init.d/httpd restart


Исправляем phpmyadmin && squirrelmail для ISPManager:

# yum --enablerepo=epel install squirrelmail
# /usr/local/ispmgr/sbin/pkgctl activate webmail
# yum --enablerepo=rpmforge install phpmyadmin
# /usr/local/ispmgr/sbin/pkgctl activate myadmin


Check out working.


Another one found php 5.2.17 repo is http://centosup.ispsystem.info/


Ключевые слова и тэги: #php5.2.17, #downgrade php 5.3 to 5.2.17, #5.2.17, #php 5.2.17 and ispmanager

Индекс цитирования