Composer - Your Composer dependencies require a PHP version more than 5.5.0. You are running 5.4.16

Материал из Wiki - Iphoster - the best ever hosting and support. 2005 - 2021
Перейти к:навигация, поиск

Доступная цена

Composer - Your Composer dependencies require a PHP version more than 5.5.0. You are running 5.4.16

При запуске composer по ssh получаем ошибку:

$ php index.php
Composer detected issues in your platform:
Your Composer dependencies require a PHP version ">= 5.5.0". You are running 5.4.16.
PHP Fatal error:  Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 5.5.0". You are running 5.4.16. in /var/www/user/data/www/site.example.com/vendor/composer/check.php on line 28

Означает, что в системе по-умолчанию, стоит PHP 5.4.x.
Достаточно в консоле указать путь к php интерпретатору версии выше, например,

$ /opt/php56/bin/php index.php

или

$ /opt/php74/bin/php index.php

Также можно указать явно версию PHP в файле composer.json:

"config": {
    "platform": {
        "php": "7.1.3"
    }
 }
Индекс цитирования