CentOS 6 - php 5.2.17 компиляция


Материал из Wiki - Iphoster - 'the best ever hosting and support

Перейти к: навигация, поиск

CentOS 6 - php 5.2.17 компиляция

# cd /tmp/
#  wget -c http://museum.php.net/php5/php-5.2.17.tar.gz
#  tar -xzvf php-5.2.17.tar.gz
#  cd php-5.2.17
#  wget http://php52-backports.googlecode.com/files/php52-backports-20130717.patch
или
# wget https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/php52-backports/php52-backports-20130717.patch
#  patch -p1 < php52-backports-20130717.patch

для i386 - --with-libdir=lib, для x64 - --with-libdir=lib64:

# ./configure --prefix=/opt/php-5.2.17 --with-config-file-path=/opt/php-5.2.17 --with-libdir=lib64 --with-mysql --with-mysqli --with-sqlite=shared --with-curl --with-gd --with-openssl --with-pdo-mysql=shared --with-pdo-sqlite=shared --with-mcrypt --with-pear --with-pic --with-jpeg-dir --with-png-dir --with-ttf --with-freetype-dir --with-xmlrpc --with-xpm-dir --with-zlib --enable-bcmath --enable-calendar --enable-cli --enable-discard-path --enable-fastcgi --enable-ftp --enable-force-cgi-redirect --enable-gd-native-ttf --enable-libxml --enable-mbstring --enable-pdo=shared --enable-soap --enable-sockets --enable-session --enable-zip --enable-zend-multibyte
# make && make install


концовка:

Installing PHP SAPI module:       cgi
Installing PHP CGI binary: /opt/php-5.2.17/bin/
Installing PHP CLI binary:        /opt/php-5.2.17/bin/
Installing PHP CLI man page:      /opt/php-5.2.17/man/man1/
Installing shared extensions:     /opt/php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613/
Installing build environment:     /opt/php-5.2.17/lib/php/build/
Installing header files:          /opt/php-5.2.17/include/php/
Installing helper programs:       /opt/php-5.2.17/bin/
 program: phpize
 program: php-config
Installing man pages:             /opt/php-5.2.17/man/man1/
 page: phpize.1
 page: php-config.1
Installing PEAR environment:      /opt/php-5.2.17/lib/php/
[PEAR] Archive_Tar    - installed: 1.3.7
[PEAR] Console_Getopt - installed: 1.2.3
[PEAR] Structures_Graph- installed: 1.0.3
[PEAR] XML_Util       - installed: 1.2.1
[PEAR] PEAR           - installed: 1.9.1
Wrote PEAR system config file at: /opt/php-5.2.17/etc/pear.conf
You may want to add: /opt/php-5.2.17/lib/php to your php.ini include_path
Installing PDO headers:          /opt/php-5.2.17/include/php/ext/pdo/
Индекс цитирования